RSS

Ubuntu 12.04: Pantalla oscura en la notebook

23 Jul

Instalé la semana pasada Ubuntu 12.04 en mi notebook “Emachines”, y ocurre un desagradable problema con el brillo de la pantalla, en donde parece que no “levantara” video, pero en realidad es que tiene el brillo demasiado bajo. La solución a este problema (que, por lo que he leído, pasa en varias marcas de notebooks) está publicada en varios lados en la Web, pero me gusta reproducirlo también acá, por si alguna vez hace falta, para mí o para quien lea esto.

El brillo es apto sólo para lechuzas…

Vamos al grano:

  1. Instalar Ubuntu desde el CD “alternate”.
  2. Finalizada la instalación, reiniciará el equipo. En ese momento, notaremos que no tenemos video (si te fijás bien, algo se ve, pero apenas se distingue).
  3. “A ciegas”, presionamos Alt+Ctrl+F1 simultáneamente. Eso nos llevará a una terminal (tty1).
  4. De nuevo a ciegas, escribimos ahí nuestro usuario y pulsamos Enter
  5. Otra vez a ciegas, escribimos nuestra contraseña, y pulsamos Enter. Hemos ingresado al sistema, pero todavía no se ve nada.
  6. Escribimos el siguiente comando:
    sudo setpci -s 00:02.0 f4.B=60
    Pulsamos Enter
  7. Volvemos a escribir nuestra contraseña y pulsamos Enter. Instantáneamente, debería comenzarse a ver la pantalla normalmente.
  8. Presionamos Ctrl+D para cerrar la sesión en el terminal, y luego Alt+Ctrl+F7 para volver al modo gráfico. Ingresamos a Ubuntu con nuestro usuario y contraseña de manera normal.
  9. Nos resta ver cómo hacemos para no tener que repetir los pasos anteriores en cada arranque del equipo. Ya en el modo gráfico, abrimos una terminal. Allí escribimos sudo gedit /etc/rc.local e ingresamos la contraseña.
  10. Se abrirá un editor de textos, editando un archivo cuyas líneas están todas comentadas, excepto la última que dice exit 0. Antes de esa última línea, agregamos la siguiente:
    sudo setpci -s 00:02.0 f4.B=60
    Guardamos y salimos. (Si se fijan bien, la línea que hay que agregar es el mismo comando que ejecutamos “a ciegas”. Se ejecutará cada vez que inicie el equipo. El número 60 mide el brillo, puede cambiarse por otro que resulte más cómodo.)
  11. ¡Listo! Ya podemos configurar el sistema a nuestro gusto.

Espero que haya servido. Ante cualquier duda, dejen un comentario.

Fuente de la imagen

 
35 comentarios

Publicado por en 23/07/2012 en Utilidades

 

Etiquetas: , , ,

35 Respuestas a “Ubuntu 12.04: Pantalla oscura en la notebook

  1. Marc LlopMarc Llop

    15/10/2012 at 18:11

    Muchas gracias!! De todos los links de google esta entrada ha sido la que me ha servido de verdad. Tengo un Acer con una GMA 4500M de gráfica. Y me pasaba lo de la pantalla en negro, aunque si acercas una luz se ve que es por falta de brillo.

    Todo lo que probaba no funcionaba, hasta encontrarte. Saludos.

     
    • Juan Marquez

      15/10/2012 at 19:04

      ¡Qué suerte que te haya sido útil! Gracias por tomarte el tiempo de dejar el comentario.

       
  2. Juan Ignacio Balaguero

    17/10/2012 at 11:32

    Me safaste profe. Tenia ese problemita con mi netbook acer aspire one y kubuntu.

     
    • Juan Marquez

      17/10/2012 at 12:52

      Qué suerte que te haya servido. Gracias por agradecer🙂. Nos vemos.

       
  3. XlethYireh

    15/11/2012 at 21:22

    Muchas Gracias, Pero no es necesario hacer todo el procedimiento “A ciegas” se puede hacer con el nomodeset activado, y luego se desactiva.

     
    • Juan Marquez

      16/11/2012 at 8:59

      Es verdad. Pero no en todas las máquinas funciona. No termino de entender muy bien por qué. Pero coincido con vos en que sería lo primero que hay que probar. Gracias por el comentario.

       
  4. edgarps5

    29/11/2012 at 10:38

    tengo una acer con una GMA 4500M de gráfica estoy tratando de instalar u buntu 12.10 esta solucion que ofreces me funcionara en esa version tambien o solo en la 12.04?

     
    • Juan Marquez

      29/11/2012 at 10:53

      No sabría decirte con seguridad, pero estimo que sí. Yo lo probé con el 11.10 y el 12.04, y en ambos casos funcionó bien, así que calculo que servirá también para esta nueva versión. Saludos.

       
  5. luiscuadrado123

    06/12/2012 at 22:57

    Pregunta importante..
    sucede que tu truco funciona de maravilla… pero al cerrar la laptop y abrirla (digamos, bajar la pantalla) baja nuevamente la luz a cero.. y queda todo en engro.. teniendo que reiniciarla de nuevo😦 o ejecutar de nuevo tus comandos..
    hay alguna forma de automatizarl para que al volver de la suspencion vuelva a poner el brillo??
    Tengo ubuntu 12.10

     
  6. Ricardo Pasc

    20/02/2013 at 17:55

    Me funciono! después de probar con varias opciones publicadas… esta al grano, y efectiva.
    Gracias

     
  7. baldo

    30/03/2013 at 23:47

    me sirvio tu articulo amigo gracias

     
  8. Marta

    01/04/2013 at 7:29

    Soy novatísima en Linux y me salvas la vida, gracias!!😀

     
  9. Juan Marquez

    01/04/2013 at 19:59

    Me alegra poder ser útil. Así funciona este mundo del Software Libre: usuarios que se ayudan entre ellos. Gracias por comentar.

     
  10. slboss

    03/04/2013 at 10:19

    Muchas gracias, funcionó perfectamente! En asus eeepc X101CH. Ubuntu 12.04

     
    • Juan Marquez

      03/04/2013 at 12:41

      Me alegro. Gracias por compartir el modelo de tu máquina. Saludos.

       
  11. Migue

    04/04/2013 at 19:06

    UUUffff que susto me he llevado al instalar linux y ver la pantalla sin brillo, pensé que se había tostado el inverter como en una ocasión anterior…. historia aparte MUCHAS GRACIAS Juanma por tu articulo, te escribo este agradecimiento desde mi escritorio linux mint 14 ahora con mucho brillo !!

     
    • Juan Marquez

      05/04/2013 at 8:12

      Qué bueno que te haya servido. Si podés, decinos el modelos de tu máquina, así vamos creando un catálogo de equipos que tienen este problema. Saludos. Juanse.

       
  12. Jose Luis Ramos

    05/04/2013 at 12:36

    Gracias a gente como tu seguimos avanzando.

     
  13. Goyena

    13/05/2013 at 7:48

    Otro náufrago al que has ayudado. Mi notebook es un Packard Bell Dot S. Es curiosos porque se me ha estropeado el brillo de la pantalla con la versión 2 (actualizada) de Ubuntu 12.04 (la estable). Gracias por tu aportación.

     
  14. David

    24/05/2013 at 21:44

    Muchas gracias!! acabo de reinstalar mi netbook con ubuntu y lo primero que me ha pasado en eso ª!!

     
  15. elisabeth

    31/05/2013 at 3:15

    gracias me ayudo mucho tenia una semana buscando solución hasta que porfin GRACIAS DE VERDAD(Y)😀

     
  16. Nspp

    14/06/2013 at 3:32

    Hola, he navegado un monton, he instalado el ultimo ubuntu 12.10, me sucede lo mismo, tengo un HP folio 13, pero pece a que hago paso a paso (alumbrando la pantalla con una linterna, unica forma en que logro ver algo), no logro solucionarlo, algun consejo?

     
    • Juan Marquez

      14/06/2013 at 11:16

      Mmmm… no sabría qué decirte. Sos el primero al que no le funciona este procedimiento. Si le encontrás la vuelta, contanos cómo lo resolviste. Suerte.

       
    • Darío

      02/10/2013 at 15:29

      Nspp a mi también me pasa lo mismo, tengo una HP 450. Si ya solicionaste tu problema te agradecería si lo puedas compartir.

       
  17. Nicolas

    14/06/2013 at 13:07

    he actualizado el S.O. ahora desde la configuracion de sistema puedo modificar la luminocidad, pero sigue presentando el problema al iniciar, la pantalla mantiene oscura hasta que manualmente lo corrijo (aumento el brillo), alguna idea de como hacerlo permanente

     
    • Darío

      02/10/2013 at 15:30

      Nicolas a mi también me pasa lo mismo, tengo una HP 450. Si ya solucionaste tu problema te agradecería si lo puedas compartir.

       
  18. CARLOS ZAVALA

    25/10/2013 at 11:25

    APAGO LA PORTATIL HP g42 Y REGRESA A LO MISMO OTRA VES SE PONE MUY OPACA

     
  19. Mijail Pisco

    09/01/2014 at 15:20

    El post me sirvio para hacer varias pruebas y concluí que:
    sudo setpci -s 00:02.0 f4.b=ff

    habilita el mayor brillo del equipo.

    Gracias!

     
  20. Jesús García

    12/01/2014 at 17:43

    lo probare al parecer si funcionara😀 mi lap es una gateway gracias

     
  21. Ruben

    04/11/2014 at 19:20

    Me aparece un letrero que dice (No devices selected for “f4.B=60”)

     

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

 
A %d blogueros les gusta esto: